5.0.4升级至5.1.0文档

5.0.4升级至5.1.0

Rainbond 5.1.0版本仅支持从5.0.4版本升级,其他5.0.x版本需要升级到5.0.4版本,5.0.4版本升级参考5.0.4升级文档;升级后可能数据库结构会发生改变,故不能够回滚升级。

无法确定Rainbond版本,可通过grctl version来确定版本。如果version不是5.0-3cbc7c6-2019-03-05-12则为非5.0.4版本

下载 5.1.0 更新包

离线包镜像大小约1.9G,需要保证当前集群磁盘可用空间至少不低于6G

# 基础Runtime包
wget http://rainbond-pkg.oss-cn-shanghai.aliyuncs.com/offline/5.1/base.images.2019-03-15-5.1.0.tgz -O /grdata/services/offline/base.images.upgrade.5.1.0.tgz

# Rainbond组件包
wget http://rainbond-pkg.oss-cn-shanghai.aliyuncs.com/offline/5.1/rainbond.images.2019-03-15-5.1.0.tgz -O /grdata/services/offline/rainbond.images.upgrade.5.1.0.tgz

# 5.1.0安装包
wget http://rainbond-pkg.oss-cn-shanghai.aliyuncs.com/offline/5.1/rainbond-ansible.upgrade.5.1.0.tgz -O /grdata/services/offline/rainbond-ansible.upgrade.5.1.0.tgz

解压安装脚本,执行升级脚本
rm -rf   /tmp/rainbond-ansible
rm -rf /grdata/services/offline/upgrade
tar xf /grdata/services/offline/rainbond-ansible.upgrade.5.1.0.tgz -C /tmp/
cd /tmp/rainbond-ansible/scripts/upgrade/
bash ./upgrade.sh
升级完成验证
grctl cluster
插件升级说明
  1. 卸载所有应用的默认插件,并在插件管理中删除默认插件
  2. 刷新页面后重新安装默认插件。
  3. 需要使用插件的应用重新安装插件并更新应用。

升级如有问题,请至社区反馈 Rainbond 5.1.0升级文档